Simplemedia for Magnolia CMS
  1. Simplemedia for Magnolia CMS
  2. MEDIA-72

some images have inverted colors when they are resized

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.2
    • Fix Version/s: 4.2.1
    • Labels:
      None

      Description

      This bug is the same as http://jira.magnolia-cms.com/browse/MGNLIMG-61, and has been fixed for magnolia imaging.
      It is reproducible by uploading the attached image, and observe the thumb in the media browser.

      We have been bulk importing images from our previous cms (95 % jpg), and about 20% was corrupted by this bug.

      Perhaps the same fix could be applied to this module.

      It would be appreciated!

        Activity

        Bert Leunis added a comment -

        In version 4.2 this problem still occurs. Here you can see the original of a jpg, and the thumbnail as shown in AdminCentral under /mediaObject/hollanddoc/2010/HD--Angela-Kaptein/resolutions/thumbnail/HD--Angela-Kaptein.jpg.

        Bert Leunis added a comment -

        Ah, very nice. Also jira has this issue. I see both original and thumbnail with a red layer over it. If you take a look at the actual files, you will see the difference.

        NB: the solution to this problem was already found and implemented by magnolia. See the mgnlimg-issue described above.

        Regards, Bert

        Fabrizio Giustina added a comment -

        Fixed in version 4.2.1, will work only if Magnolia is running on top on a Sun JRE (the decoder used is only available in the Sun jre).

        Note that this fix is more tricky for the media module because it already supports some non standard jpeg flavours that are not working in the imaging module (adobe ycck). The current solution for supporting all the jpeg formats is:

        -> analyze the jpeg exif
          -> if ycck convert it using a custom code
          -> if not ycck try the sun decoder
             -> if the sun decoder is not available or it can't parse the image use the standard ImageIO
        
        Ernst Bunders added a comment -

        This issue is still not fixed. We are currently using version 4.5.0, and we still see the flawed thumbnail images.


          People

          • Assignee:
            Fabrizio Giustina
            Reporter:
            Ernst Bunders
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: